同花顺必涨之星副图指标 源码

admin股票百科2019-12-13 09:04:3740ema

必涨之星
作为买卖参考,有买卖提示,无未来函数
使用时请参考macd,大盘,成交量等因素。

////主力动向 主力趋势雷达///
r0:=((IF(ISNULL(ZDMR[-1]),0,ZDMR) IF(ISNULL(BDMR[-1]),0,BDMR))-(IF(ISNULL(ZDMC[-1]),0,ZDMC) IF(ISNULL(BDMC[-1]),0,BDMC)))/SHGZG*100;
MA5:=MA(r0,5);
超买:3.2,coloryellow;
//超卖:0.5,coloryellow;//让位花神线
最小值:=LLV(LOW,10);
最大值:=HHV(HIGH,25);
波动线:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);
平均线:EMA(波动线,3);
主力攻击:=r0-(ABS(REF(r0,1)) ABS(REF(r0,2)) ABS(REF(r0,3)) ABS(REF(r0,4)) ABS(REF(r0,5))/2)0 AND 平均线=REF(平均线,1) AND REF(平均线,1)REF(平均线,2);
主力撤退:=-((r0 (ABS(REF(r0,1)) ABS(REF(r0,2)) ABS(REF(r0,3)) ABS(REF(r0,4)) ABS(REF(r0,5))/2)0) AND 平均线=REF(平均线,1) AND REF(平均线,1)REF(平均线,2));
DRAWTEXT(主力攻击0,1.5,主进),colorred;
DRAWTEXT(主力撤退0,2.8,主退),colorgreen;
信息:=平均线=REF(平均线,1);
走强:=CLOSEMA(CLOSE,20)AND CLOSEMA(CLOSE,5);
走弱:=CLOSEMA(CLOSE,10)AND CLOSEMA(CLOSE,5);
量:=VOLMA(VOL,5);
STICKLINE(平均线=REF(平均线,1),波动线,REF(波动线,1),5,0),colorred;
STICKLINE(平均线REF(平均线,1),波动线 ,REF(波动线,1),5,0),colorgreen;
d:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2) REF(信息,3)=0) AND 平均线0.5;
s:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2) REF(信息,3)=0) AND 走强=1 AND REF(走强,1)=0 AND 量=1;
dd:=平均线2 AND (信息=0 AND REF(信息,1)=1) AND (REF(信息,2) REF(信息,3)=2);
tz:=(信息=0 AND REF(信息,1)=1) AND (REF(信息,2) REF(信息,3)=2) AND MA50 AND 走弱=1 AND 平均线1;
DRAWTEXT(d=1,1.75,'极底'),colorred;
DRAWTEXT(s=1,平均线,'升');
DRAWTEXT(dd=1,平均线,'顶');
DRAWTEXT(tz=1,平均线,'下');
PARTLINE(平均线,平均线=REF(平均线,1),colorred,平均线REF(平均线,1),colorgreen);
////机构建仓////
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD 0) AND (HD LD)),HD,0),10);
DMM:=SUM(IF(((LD 0) AND (LD HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI PDI)) * 100),5);
AV:=(RSI5 ADX);
最佳买入:=(AV NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
VAR5:=SMA(最佳买入选股,3,1);
VAR6:=SMA(VAR5,3,1);
VAR7:=SMA(VAR6,3,1);
建仓买点:=IF(CROSS(VAR6,VAR7) AND (VAR640),5,0* 10000);
DRAWTEXT(建仓买点,0.75,'建仓'),colorred;
////机构利器////
VAR8:=REF(CLOSE,2);
会员:=SMA(MAX(CLOSE-VAR8,0),7,1)/SMA(ABS(CLOSE-VAR8),7,1)*100;
逃亡:=IF(会员 REF(会员,1) AND 会员79,会员,0);
DRAWTEXT(逃亡,3.1,'逃'),coloryellow;
DRAWTEXT(880 AND REF(O,1)/REF(C,1)1.04 AND REF(L,1)=688 AND OREF(C,1)AND CREF(O,1)AND C/O=1.01,1,'见底'),colorred;
DRAWTEXT(C-O=0 AND O/L1.05 AND L=LLV(L,20),1,'绝底'),colorred;
///主力吸货////
VAR11:=REF(LOW,1);
VAR12:=SMA(ABS(LOW-VAR11),3,1)/SMA(MAX(LOW-VAR11,0),3,1)*100;
VAR13:=EMA(IF(CLOSE*1.2,VAR12*10,VAR12/10),3);
VAR14:=LLV(LOW,38);
VAR15:=HHV(VAR13,38);
VAR16:=IF(LLV(LOW,90),1,0);
VAR17:=EMA(IF(LOW=VAR14,(VAR13 VAR15*2)/2,0),3)/618*VAR16;
Cdxs:=HHV(VAR17,0)/2.6;
STICKLINE(VAR17,0.53,VAR17/Cdxs 0.53,1,0),colorwhite;
////马上成功////
Hua:=(CLOSE - LLV(LOW,14)) / (HHV(HIGH,14) - LLV(LOW,14)) * 1.2 * CLOSE;
Nv1:=EMA(Hua,4);
Nv2:=EMA(Hua,8);
DRAWICON(CROSS(Nv1,Nv2) AND CLOSE/OPEN1.05,0.5,1);
DRAWICON(CROSS(Nv2,Nv1) AND COUNT(CROSS(Nv1,Nv2) AND CLOSE/OPEN1.05 ,20) ,3.2,2);
////必涨之星////
Hua2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),16,2)/SMA(ABS(CLOSE/REF(CLOSE,1)),16,2)*100;
Xian=SMA(Hua2,3,1);
Nv3:=SMA(Xian,3,1);
XiNv=3*Xian-2*Nv3;
买入条件:=CROSS(XiNv,Nv3);
卖出条件:=CROSS(Nv3,XiNv);
DRAWICON( 卖出条件,3.3,2),coloryellow;
DRAWICON(买入条件,0.4,222),colorwhite;//必涨之星
Hxn:=IF(CLOSE/REF(CLOSE,1)1.05 AND HIGH/CLOSE1.01 AND IF(CLOSEREF(CLOSE,1),88,0)0, 91, 0);//花仙女涨停
DRAWTEXT(Hxn90 AND VOLREF(VOL,1) AND CLOSEREF(CLOSE,1) AND COUNT(Hxn90,30)=1,平均线-0.25, '见涨'),,colorlired;
Hxjz:=MA((2*CLOSE HIGH LOW)/4,5);//花仙女绝招
Bztd:=Hxjz*89/100;
DRAWTEXT(CROSS(LOW,Bztd),1.25,'必涨'),colorred;
////花神////
花:=EMA(SLOPE(1,1) C,3),colorred;
女:=EMA(SLOPE(1,1) C,7),colorblue;
STICKLINE(花女 ,0.5,0.53,12,0) ,colorred;//花神线,红色开始为买
STICKLINE(花=女 ,0.5,0.53,12,0),colorgreen;//花神线,绿色开始为卖


分享: