KDJ和MACD金叉共振公式

KDJ和macd金叉共振公式

通达信副图

DIF:(ema(CLOSE,6)-EMA(CLOSE,26))*100;
dea:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORstICK;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
IF(DIF
DD:=C=HHV(C,180);
EE:=DEA REF(DEA,1) AND REF(DEA REF(DEA,1),1)=1;
CC:=C REF(C,1) AND REF(C REF(C,1),1)=1;
顶背离:=(DD AND EE AND DEA HHV(DEA,180))*DEA;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
{顶背:=REF(CLOSE,A2 1)DIF AND CROSS(DEA,DIF);}
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORRED,LINethICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(high,9)-LLV(LOW,9))*100;
K:sma(RSV,9,3),COLORYELLOW;
D:SMA(K,9,3),COLORWHITE;
J:3*K-2*D,COLORMAGENTA;
IF(J
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A1 1)C AND REF(DIF,A1 1)
A22:=BARSLAST(REF(CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3)),1));
B2:=REF(C,A22 1)C AND REF(KDJ.K(9,3,3),A22 1)KDJ.K(9,3,3) AND CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3));
A3:=BARSLAST(REF(CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24)),1));
b3:=REF(C,A3 1)C AND REF(RSI.RSI1(6,12,24),A3 1)RSI.RSI1(6,12,24) AND CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24));
DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;
DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORFF00FF;
{DJ:=CROSS(J,D) AND D20;
DRAWTEXT(DJ,J-0.3,'低金叉'),COLORCYAN;
MDJ:=CROSS(DIF,DEA) AND DEA0;
DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORGREEN;
DRAWTEXT(CROSS(DEA,DIF),DIF 0.3,'死叉'),COLORYELLOW;
DRAWTEXT(CROSS(D,J),J 0.3,'死叉'),COLORRED;}
A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);
DRAWICON(A,LOW*0.98,1);
B4:CROSS(DIF,DEA) AND CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3));
DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;
DRAWICON(CROSS(K,D),D,1);
DRAWICON(CROSS(D,K),D,2);
BA:=DEAREF(DEA,1);
BB:=SUM(BA,5)=4;
BC:=C
BD:=SUM(BC,5)=2;
BXG:FILTER(BB AND BD AND JREF(J,1) AND REF(J,1)
STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;

分享: