J线共振通达信源码

admin股票百科2019-11-11 04:40:573

RSV1:=(close-LLV(LOW,27))/(HHV(high,27)-LLV(LOW,27))*100;
K1:=sma(RSV1,5,1);
D1:=SMA(K1,5,1);
J1:=3*K1-2*D1;
AA1:=ema(J1,5);
AA2:=REF(AA1,1);
stICKLINE(AA1AA2,AA1,AA2,4,0),COLOR0055AA;{长J}
STICKLINE(AA1AA2,AA1,AA2,4,0),COLOR0077CC;
STICKLINE(AA1AA2,AA1,AA2,2,0),COLOR0099DD;
STICKLINE(AA1AA2,AA1,AA2,1,0),COLOR01BEE7;
STICKLINE(AA1=AA2,AA1,AA2,4,0),COLOR006600;
STICKLINE(AA1=AA2,AA1,AA2,4,0),COLOR009900;
STICKLINE(AA1=AA2,AA1,AA2,2,0),COLOR00BB00;
STICKLINE(AA1=AA2,AA1,AA2,1,0),COLOR00CC00;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
STICKLINE(BB1BB2,BB1,BB2,4,0),COLOR000045;{短J}
STICKLINE(BB1BB2,BB1,BB2,3,0),COLOR000085;
STICKLINE(BB1BB2,BB1,BB2,2,0),COLOR0000C5;
STICKLINE(BB1BB2,BB1,BB2,1,0),COLOR0000E5;
STICKLINE(BB1=BB2,BB1,BB2,4,0),COLOR353500;
STICKLINE(BB1=BB2,BB1,BB2,3,0),COLOR555500;
STICKLINE(BB1=BB2,BB1,BB2,2,0),COLOR757500;
STICKLINE(BB1=BB2,BB1,BB2,1,0),COLOR858500;
DD:=AA1AA2 AND BB1BB2;
注意买入:DD AND NOT(REF(DD,1)) AND (AA150 OR BB150) ,LINethICK0;
DRAWicoN(注意买入,-5,1);
注意卖出:REF(DD,1)=1 AND NOT(DD),LINETHICK0;
DRAWICON(注意卖出,105,2);



分享: