「通达信」三重指数平均线TRIX指标公式

N:=12;N1:=9;S1:=1;P:=10;
{TRIX(3D)}
MTR:=EMA(EMA(EMA(CLOSE,N),N),N);
TRIX:(MTR-REF(MTR,1))/REF(MTR,1)*100,COLORSTICK;
MATRIX:IF(S1>0,MA(TRIX,N1),DRAWNULL),COLORGRAY,DOTLINE;
UPO:=IF(TRIX>=0,TRIX,DRAWNULL);
UP: P*EMA(UPO,38),COLOR5A9A00;
DNO:=IF(TRIX<=0,TRIX,DRAWNULL);


AB:=TRIX;
STICKLINE(ABSTICKLINE(ABSTICKLINE(ABSTICKLINE(ABSTICKLINE(AB>REF(AB,1),0,AB,3.6,0),COLOR000099;
STICKLINE(AB>REF(AB,1),0,AB,3,0),COLOR0000CC;

5,0),COLOR0000FF;
STICKLINE(AB>REF(AB,1),0,AB,0.5,0),COLORCC66FF;

分享: