「通达信」土造EXPMA主图指标公式

M1:=9;
M2:=55;
EXP1:EXPMA(CLOSE,M1);
EXP2:EXPMA(CLOSE,M2);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.97,买吧) ,
LINETHICK2,COLOR00FFFF;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.99,1);
DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),H,2);
AZ6:=(3 * (SMA((((CLOSE (LLV(LOW,27))) /
((HHV(HIGH,27)) (LLV(LOW,27)))) * 100),5,1))) (2 * (SMA((SMA((((CLOSE
(LLV(LOW,27))) / ((HHV(HIGH,27)) (LLV(LOW,27)))) * 100),5,1)),3,1)));
B7:=(10);
DRAWTEXT(CROSS(AZ6,B7),L,),COLOR0000FF;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));
DRAWTEXT((VARC=1),L,追呀),COLOR0000FF;
DRAWTEXT((VARD=1),H,跑吧),COLOR00FF00;
DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORE88300,LINETHICK2;

分享: