「通达信」安全仓主图指标公式

admin炒股技巧2019-12-05 00:23:212

N:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),MA(C,N*0.7),4,0),COLORYELLOW;
stICKLINE(CDRAWKLINE(H,O,L,C);
上线:=sma(C,6.5,1);
下线:=SMA(C,13.5,1);
上线1:=SMA(C,3,1);
下线1:=SMA(C,8,1);
STICKLINE(上线>下线,上线,下线,2,2),COLORBLUE,LINethICK3;
STICKLINE(下线>上线,上线,下线,2,2),COLORGREEN,LINETHICK3;
DRAWTEXT(CROSS(上线,下线),LOW,●
全仓买),COLOR00FF00;
DRAWTEXT(CROSS(下线1,上线1),H,◆
清仓),COLORYELLOW;
BBI:=(MA(CLOSE,3) MA(CLOSE,6) MA(CLOSE,12) MA(CLOSE,24))/4;
UPR:=BBI 3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) , high,◆
减仓) ,COLORFF9966,LINETHICK2;
A7:=(2*C H L)/4;
操作:MA(A7,5),LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
安全线:LLV(A7,21);
风险线:HHV(A7,21);
SK:=ema((A7-安全线)/(风险线-安全线)*100,7);
SD:=EMA(0.667*REF(SK,1) 0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,●
买进) ,COLOR0099FF;
DRAWTEXT(IF(COUNT(CLOSE6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.98,●
买进) ,COLORYELLOW;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE抄底),COLORYELLOW;
总资金(万):AMOUNT/10000,COLORFF00FF,NODRAW;
VAR20:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
流入万:IF(CLOSE>OPEN,VAR20*(HIGH-LOW),IF(CLOSE流出万:IF(CLOSE>OPEN,0-VAR20*((HIGH-CLOSE) (OPEN- LOW)),IF(CLOSE差额万:流入万 流出万,COLORFFFF00,NODRAW;
{};
VAR31:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR32:=REF(VAR31,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR33:=REF(VAR32,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR34:=REF(VAR33,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR35:=REF(VAR34,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR36:=REF(VAR35,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR37:=REF(VAR36,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR38:=REF(VAR37,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR39:=REF(VAR38,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
{www.gainiangu.com 概念股网_通达信股票指标公式}
VARA:=REF(VAR39,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR110:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR111:=REF(VAR110,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR112:=REF(VAR111,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR113:=REF(VAR112,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR114:=REF(VAR113,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR115:=REF(VAR114,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR116:=REF(VAR115,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR117:=REF(VAR116,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR118:=REF(VAR117,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR119:=REF(VARD OR VARE OR VARF OR VAR110 OR VAR111 OR VAR112 OR VAR113 OR
VAR114 OR VAR115 OR VAR116 OR VAR117 OR VAR118,1) AND VAR31;
VAR1A:=REF(VAR31 OR VAR32 OR VAR33 OR VAR34 OR VAR35 OR VAR36 OR VAR37 OR
VAR38 OR VAR39 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWTEXT(FILTER(VAR119=1,5),LOW, 买进),COLORFF00FF;
DRAWICON(FILTER(VAR119=1,5),LOW,9);
DRAWTEXT(FILTER(VAR1A=1,5),HIGH, 逃顶),COLOR00FF00;
DRAWICON(FILTER(VAR1A=1,5),HIGH,15);

分享: