「通达信」KDJ全波段指标公式

admin炒股技巧2019-12-13 09:12:5137

ZJ1:=MA(KDJ.J#WEEK(9,3,3) ,5);
STICKLINE(ZJ1>=0 AND ZJ1>=REF(ZJ1,1),0,100,4,0),COLORAA0077;
STICKLINE(ZJ1<0 ,0,50,4,0),COLOR060066;
STICKLINE(ZJ1<0 AND ZJ1>=REF(ZJ1,1),0,100,4,0),COLOR000088;
YK:=MA(KDJ.K#MONTH(9,3,3),20);
YD:=MA(KDJ.D#MONTH(9,3,3),20);
YJ:=MA(KDJ.J#MONTH(9,3,3),20);
STICKLINE(YK>=YD,YK,YD,1,0),COLOR880088;
STICKLINE(YKZK:=MA(KDJ.K#WEEK(9,3,3) ,5);
ZD:=MA(KDJ.D#WEEK(9,3,3) ,5);
DRAWBAND(ZK,RGB(200,0,0),ZD,RGB(0,200,200));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWBAND(K,RGB(250,0,200),D,RGB(200,170,100));
日金叉:IF(CROSS(K,D),7,0),COLORMAGENTA,LINETHICK2;
DRAWBAND(日金叉,RGB(250,0,250),0,RGB(0,0,0));
日死叉: IF(CROSS(D,K),93,100), COLOR00FF00,LINETHICK2;
DRAWBAND(100,RGB(0,250,0),日死叉,RGB(0,0,0));
{www.gUPang.com 概念股网_最新股票指标公式}
周金叉:IF(CROSS(ZK,ZD),12,0),COLORRED,LINETHICK2;
DRAWBAND(周金叉,RGB(250,0,0),0,RGB(0,0,0));
周死叉:IF(CROSS(ZD,ZK),87,100), COLORFFFF00,LINETHICK2;
DRAWBAND(100,RGB(0,250,250),周死叉,RGB(0,0,0));
月金叉:IF(CROSS(YK,YD),17,0),COLORYELLOW,LINETHICK2;
DRAWBAND(月金叉,RGB(250,250,0),0,RGB(0,0,0));
月死叉:IF(CROSS(YD,YK),82,100),COLORFF0000,LINETHICK2;
DRAWBAND(100,RGB(0,0,250),月死叉,RGB(0,0,0));
IF(ZJ1<=0,0,DRAWNULL),COLORRED,LINETHICK4;
IF(ZJ1>85,ZJ1,DRAWNULL),COLOR00FFFF,LINETHICK2;
IF(ZJ1>85,100,DRAWNULL),COLOR00FFFF,LINETHICK4;
AA:=IF(ZJ1<0 AND ZJ1BB:=IF(ZJ1<0 AND ZJ1>=REF(ZJ1,1),-8,0),COLOR000088;
DRAWBAND(0,RGB(150,200,0),AA,RGB(0,0,0));
DRAWBAND(0,RGB(200,50,150),BB,RGB(0,0,0));
ZJ:ZJ1,COLOR0000FF,LINETHICK2;
IF(ZJIF(ZJ<0 AND ZJIF(ZJ<0 AND ZJ=REF(ZJ,1),ZJ,DRAWNULL),COLOR0000FF,LINETHICK2;
STICKLINE(C>0,50,50,2,0),COLOR00FFFF;
DRAWTEXT_FIX(1,0.4,0.1,0,★★ 深红色提示准备★★暗红色买入区★★紫粉色加仓区★★顶部黄色带风险提示★★),COLORFFFFFF;

分享: