「通达信」短进短出主图指标公式

MA5:MA(C,5),COLORWHITE,LINethICK2;
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60),COLORGREEN;
ma10:MA(CLOSE,10),COLORMAGENTA,LINETHICK2;
JG:=CROSS(MA5,MA10);
GJ:=IF(CROSS(MA10,MA5),0,1);
VOLUME:=VOL,VOLstICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
NL:=CROSS(MAVOL1,MAVOL2);
DIF:=ema(CLOSE,12)-EMA(CLOSE,26);
dea:=EMA(DIF,9);
macd:=(DIF-DEA)*2,COLORSTICK;
NA:=CROSS(DIF,DEA);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(high,9)-LLV(LOW,9))*100;
K:=sma(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
DRAWTEXT((JG AND NA) AND J<80,L-0.09,'稳进'),COLORYELLOW;
X:=IF(DIF>0,1,0);
Y:=IF(J<80,1,0);
{DRAWTEXT(IF(X>0 AND Y>0 AND GJ>0,1,0),L 0.09,★短进),COLORLIMAGENTA;}
DRAWTEXT(CROSS(DEA,DIF),H 0.09,★短出),COLORLIMAGENTA;
{概念股网-股票公式网站 www.gainiangu.com}
JH9:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH9),H 0.09,★S),COLORGREEN;
PT:=XMA(H,20);
PAN:=XMA(CLOSE,7),COLORBROWN;
RUO:=MEMA(CLOSE,3),COLORLIBLUE;
DRAWTEXT(LONGCROSS(PAN,RUO,0.25) AND PT>H ,L-0.09,★短进),COLORRED;

分享: