「大智慧」黄金分割主图指标公式

admin炒股技巧2019-11-10 07:50:595黄金分割

input:K(1,1,3);
T:=BARSLAst(DISPSTATUS=1) 1;
A:=DISPSTATUS=2;HH:=HHV(H, T);LL:=LLV(L, T);HL:=HH-LL;wH:=HHVBARS(H, T);wL:=LLVBARS(L, T);
KK:=wH-wL;mHL:=HH-HL*0.5;
if K=1 then begin
HL191:=(HH-LL)*0.191;HL382:=(HH-LL)*0.382;HL618:=(HH-LL)*0.618;HL809:=(HH-LL)*0.809;
if KK<0 then begin
a1:=HH-HL191;a2:=HH-HL382;a3:=HH-HL618;a4:=HH-HL809;
end else begin
a1:=LL HL191;a2:=LL HL382;a3:=LL HL618;a4:=LL HL809;
end end
if k=1 then begin
HL125:=(HH-LL)*0.125;HL250:=(HH-LL)*0.25;HL375:=(HH-LL)*0.375;HL625:=(HH-LL)*0.625;HL750:=(HH-LL)*0.75;HL875:=(HH-LL)*0.875;
if kk<0 then begin
b1:=HH-HL125;b2:=HH-HL250;b3:=HH-HL375;b4:=HH-HL625;b5:=HH-HL750;b6:=HH-HL875;
end else begin
b1:=LL HL125;b2:=LL HL250;b3:=LL HL375;b4:=LL HL625;b5:=LL HL750;b6:=LL HL875;
end end
DRAWTEXT(A and K<>3,HH, 最高价: HH),ALIGn2,ColorFF00FF;
DRAWTEXT(A and K<>3,LL, 最低价: ll),ALIGN2,VALIGN2,Color00FF00;
DRAWTEXT(A and K<>3,mHL,50%: mHL),ALIGN2,ColorFF8000;
DRAWTEXT(A and K=1, a1, 0.191: NUMTOSTRN(a1,2)),ALIGN2,Color4080FF;
DRAWTEXT(A and K=1, a2, 0.382: NUMTOSTRN(a2,2)),ALIGN2,Color4080FF;
DRAWTEXT(A and K=1, a3, 0.618: NUMTOSTRN(a3,2)),ALIGN2,Color4080FF;
DRAWTEXT(A and K=1, a4, 0.809: NUMTOSTRN(a4,2)),ALIGN2,Color4080FF;
DRAWTEXT(A and K=1, b1, 1/8: NUMTOSTRN(b1,2)),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b2, 1/4: NUMTOSTRN(b2,2)),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b5, 3/4: NUMTOSTRN(b5,2)),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b6, 7/8: NUMTOSTRN(b6,2)),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K<>3,HH,  ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,LL,  ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,mHL, ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄),ALIGN2,ColorFF8000,linethick7;
DRAWTEXT(A and K=1, a1, ﹊﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a2, ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a3, ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊﹊),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a4, ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊﹊),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, b1, ﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b2, ﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b5, ﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉),ALIGN2,ColorC0C0C0;
DRAWTEXT(A and K=1, b6, ﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉),ALIGN2,ColorC0C0C0;
市场成本:DMA(AMOUNT/V/100,V/CAPITAL),Color0080FF,LINETHICK1;
DRAWicoN(CROSS(C,市场成本),L,1),ALIGN1;
PT:= REF(high,1)-REF(LOW,1);
重心:=(HIGH LOW CLOSE)/3;
压力Ⅰ:=2*重心-LOW;压力Ⅱ:= 重心 PT;
支撑Ⅰ:=2*重心-HIGH;支撑Ⅱ:= 重心 PT;
DRAWTEXTABS(50,68, 重心: 重心),Color208FFF;
DRAWTEXTABS(20,87, 支 撑),Color00FF00;
DRAWTEXTABS(20,104, 支撑Ⅰ),Color00FF00;
DRAWTEXTABS(20,122, 支撑Ⅱ),Color00FF00;
DRAWTEXTABS(25,87, 压 力),ColorFF00FF;
DRAWTEXTABS(25,104, 压力Ⅰ),ColorFF00FF;
DRAWTEXTABS(25,122, 压力Ⅱ),ColorFF00FF;
DRAWTEXTABS(25,65,│),Color00FFFF;
DRAWTEXTABS(25,77,│),Color00FFFF;
DRAWTEXTABS(25,89,│),Color00FFFF;
{概念股网-股票公式网站 www.gainiangu.com}
DRAWTEXTABS(25,101,│),Color00FFFF;
DRAWTEXTABS(25,113,│),Color00FFFF;
DRAWTEXTABS(25,125,│),Color00FFFF;
DRAWTEXTABS(170,65,│),Color00FFFF;
DRAWTEXTABS(170,77,│),Color00FFFF;
DRAWTEXTABS(170,89,│),Color00FFFF;
DRAWTEXTABS(170,101,│),Color00FFFF;
DRAWTEXTABS(170,113,│),Color00FFFF;
DRAWTEXTABS(170,125,│),Color00FFFF;
DRAWTEXTABS(96,85,│),Color00FFFF;
DRAWTEXTABS(96,89,│),Color00FFFF;
DRAWTEXTABS(96,101,│),Color00FFFF;
DRAWTEXTABS(96,113,│),Color00FFFF;
DRAWTEXTABS(96,125,│),Color00FFFF;
DRAWTEXTABS(30,60,──────────),Color00FFFF;
DRAWTEXTABS(30,80,──────────),Color00FFFF;
DRAWTEXTABS(30,97,──────────),Color00FFFF;
DRAWTEXTABS(30,114,──────────),Color00FFFF;
DRAWTEXTABS(30,131,──────────),Color00FFFF;
G:=ZIG(3,5)>REF(zig(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
X:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
ED:=barslast(G);
EF:=barslast(X);
DRAWTEXTREL(25,410,买入: NUMTOSTR(ED) 天 卖出: NUMTOSTR(EF) 天 ),colorFfff00;
{K线优化}
STICKLINE(close>=open,open,close,8,1),colorred;
STICKLINE(open>close,close,open,8,0 ),ColorFFFF00;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),ColorFFFF00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),ColorFFFF00;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,8,0),Color00FFFF;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,8,0),ColorFF8000;
{粉兰色K线};
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(Cp1:=今小昨;
今小前:=IF(Cp2:=今小前;
stickline(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,open,CLOSE,6,0),COLORMAGENTA;
stickline(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,open,CLOSE,3,0),COLORBLUE;
DRAWTEXT(G,L*0.997,△),ALIGN1,VALIGN0,Color00FF00;
DRAWTEXT(G,L, ̄),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(X,H*1.002,▽),ALIGN1,VALIGN2,ColorFF00FF;
DRAWTEXT(X,H, ̄),ALIGN1,VALIGN0,ColorFF00FF;
DRAWTEXTREL(130,25,所属板块: BKNAME),COLORFFFFFF;
今市上涨家数:=INDEXADV;
平盘家数:=DYNAINFO(68);
今市下跌家数:=INDEXDEC;

分享: