「通达信」自用CCI主图指标公式

AAF:LLV(LOW,34),LINethICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (high LOW CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;

015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1 CCI2 CCI3 CCI4 CCI5;
aaa:=(3*C H L O)/6;


VAR2:=(HHV(VAR1,5) HHV(VAR1,10) HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5) LLV(VAR1,10) LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5) HHV(VAR2,10) HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5) LLV(VAR3,10) LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;


TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0),NODRAW;
TJ2:=IF(BARSLAst(立桩量)=1 ,1,0);
{www.gainiangu.com 概念股网_通达信股票指标公式}
STICKLINE(立桩量 !=1,REF(HIGH,BARSLAST(立桩量)),
REF(HIGH,BARSLAST(立桩量)),1,1),COLORCYAN;
{STICKLINE(立桩量 !=1,REF(LOW,BARSLAST(立桩量)),
REF(LOW,BARSLAST(立桩量)),1,1),COLORCYAN;


条件成立1:=FILTER(成立1,5);
DRAWTEXT(条件成立1, REF(HIGH,BARSLAST(立桩量)),看跌),COLORLIBLUE;
TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0),NODRAW;
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量2)),
REF(HIGH,BARSLAST(立桩量2)),1,1),COLORYELLOW;

= VAR6,REF(LOW,BARSLAST(立桩量2)),
REF(LOW,BARSLAST(立桩量2)),1,1),COLORYELLOW;
TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
条件成立2:=FILTER(成立2,5);
DRAWTEXT(条件成立2,REF(LOW,BARSLAST(立桩量2)),看涨),COLORLIMAGENTA;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立桩量3:=FILTER(TJ111,3);


成立:=TJ3=1;
条件成立:=FILTER(成立,5);
DRAWTEXT(条件成立 AND 下跌!= VAR6,L*0.97,☆成立);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE LC),0),3,1) / SMA(ABS((CLOSE LC)),3,1)) * 100);
FF:=ema(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),BBF,底背离),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.


X1:=(C L H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,45),COLORWHITE;
STICKLINE(1,C,O,2.8,0),COLOR666600;
STICKLINE(立桩量,C,O,2.8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORcccCCC;

分享: