「通达信」经典短中长线彩带主图指标公式

N:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),MA(C,N*0.78),4,0),COLORYELLOW;
STICKLINE(CDRAWKLINE(H,O,L,C);
M:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),MA(C,M*0.7),4,0),COLORYELLOW;

7),4,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,3);
VAR5:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
D1:DRAWTEXT(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)

3,LOW ,'★B'),COLORGREEN;
D3:DRAWTEXT(CROSS(VAR4,5) AND VAR3<-0.4,LOW ,'★B'),COLORBLUE;
Y:=MA(C,120);
VAR6:=(MA(C,5)-Y)/Y;
VAR7:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
VAR8:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);


E2:DRAWTEXT(CROSS(90,VAR4) AND VAR5>0.2,HIGH,★S),COLORGREEN;
E3:DRAWTEXT(CROSS(95,VAR4) AND VAR3>0.5,HIGH ,★S),COLORRED;

分享: