「通达信」时间筹码主图指标公式

admin炒股技巧2019-12-13 09:33:2917

{时间上10分上市日期}
A0:=IF(CURRBARSCOUNT=1,BARSSINCE(C>0),DRAWNULL);
{第二阶段分段}
A11:=INTPART(IF(A0>0,A0*0.15,0));
STICKLINE(CURRBARSCOUNT<36 AND A11>0,REF(C,A11),REF(C,A11),A0*0.85,-1)COLORGRAY;
A12:=INTPART(IF(A0>0,A0*0.25,0));
STICKLINE(CURRBARSCOUNT<36 AND A12>0,REF(C,A12),REF(C,A12),A0*0.75,-1)COLORGRAY;
A13:=INTPART(IF(A0>0,A0*0.35,0));
STICKLINE(CURRBARSCOUNT<36 AND A13>0,REF(C,A13),REF(C,A13),A0*0.65,-1)COLORGRAY;
A14:=INTPART(IF(A0>0,A0*0.45,0));
STICKLINE(CURRBARSCOUNT<36 AND A14>0,REF(C,A14),REF(C,A14),A0*0.55,0-1)COLORGRAY;
A15:=INTPART(IF(A0>0,A0*0.55,0));
STICKLINE(CURRBARSCOUNT<36 AND A15>0,REF(C,A15),REF(C,A15),A0*0.45,0-1)COLORGRAY;
A16:=INTPART(IF(A0>0,A0*0.65,0));
STICKLINE(CURRBARSCOUNT<36 AND A16>0,REF(C,A16),REF(C,A16),A0*0.35,0-1)COLORGRAY;
A17:=INTPART(IF(A0>0,A0*0.75,0));
STICKLINE(CURRBARSCOUNT<36 AND A17>0,REF(C,A17),REF(C,A17),A0*0.25,0-1)COLORGRAY;
A18:=INTPART(IF(A0>0,A0*0.85,0));
STICKLINE(CURRBARSCOUNT<36 AND A18>0,REF(C,A18),REF(C,A18),A0*0.15,0-1)COLORGRAY;
A19:=INTPART(IF(A0>0,A0*0.95,0));
STICKLINE(CURRBARSCOUNT<36 AND A19>0,REF(C,A19),REF(C,A19),A0*0.05,0-1)COLORGRAY;
{第三阶段分段}
A21:=INTPART(IF(A0>0,A0*0.17,0));
STICKLINE(CURRBARSCOUNT<36 AND A21>0,REF(C,A21),REF(C,A21),A0*0.83,-1)COLORLIGREEN;
A22:=INTPART(IF(A0>0,A0*0.27,0));
STICKLINE(CURRBARSCOUNT<36 AND A22>0,REF(C,A22),REF(C,A22),A0*0.73,-1)COLORLIGREEN;
A23:=INTPART(IF(A0>0,A0*0.37,0));
STICKLINE(CURRBARSCOUNT<36 AND A23>0,REF(C,A23),REF(C,A23),A0*0.63,-1)COLORLIGREEN;
A24:=INTPART(IF(A0>0,A0*0.47,0));
STICKLINE(CURRBARSCOUNT<36 AND A24>0,REF(C,A24),REF(C,A24),A0*0.53,0-1)COLORLIGREEN;
A25:=INTPART(IF(A0>0,A0*0.57,0));
STICKLINE(CURRBARSCOUNT<36 AND A25>0,REF(C,A25),REF(C,A25),A0*0.43,0-1)COLORLIGREEN;
A26:=INTPART(IF(A0>0,A0*0.67,0));
STICKLINE(CURRBARSCOUNT<36 AND A26>0,REF(C,A26),REF(C,A26),A0*0.33,0-1)COLORLIGREEN;
A27:=INTPART(IF(A0>0,A0*0.77,0));
STICKLINE(CURRBARSCOUNT<36 AND A27>0,REF(C,A27),REF(C,A27),A0*0.23,0-1)COLORLIGREEN;
A28:=INTPART(IF(A0>0,A0*0.87,0));
STICKLINE(CURRBARSCOUNT<36 AND A28>0,REF(C,A28),REF(C,A28),A0*0.13,0-1)COLORLIGREEN;
A29:=INTPART(IF(A0>0,A0*0.97,0));
STICKLINE(CURRBARSCOUNT<36 AND A29>0,REF(C,A29),REF(C,A29),A0*0.03,0-1)COLORLIGREEN;
{第四阶段分段}
A31:=INTPART(IF(A0>0,A0*0.13,0));
STICKLINE(CURRBARSCOUNT<36 AND A31>0,REF(C,A31),REF(C,A31),A0*0.87,-1)COLORLIGREEN;
A32:=INTPART(IF(A0>0,A0*0.23,0));
STICKLINE(CURRBARSCOUNT<36 AND A32>0,REF(C,A32),REF(C,A32),A0*0.77,-1)COLORLIGREEN;
A33:=INTPART(IF(A0>0,A0*0.33,0));
STICKLINE(CURRBARSCOUNT<36 AND A33>0,REF(C,A33),REF(C,A33),A0*0.67,-1)COLORLIGREEN;
A34:=INTPART(IF(A0>0,A0*0.43,0));
STICKLINE(CURRBARSCOUNT<36 AND A34>0,REF(C,A34),REF(C,A34),A0*0.57,0-1)COLORLIGREEN;
A35:=INTPART(IF(A0>0,A0*0.53,0));
STICKLINE(CURRBARSCOUNT<36 AND A35>0,REF(C,A35),REF(C,A35),A0*0.47,0-1)COLORLIGREEN;
A36:=INTPART(IF(A0>0,A0*0.63,0));
STICKLINE(CURRBARSCOUNT<36 AND A36>0,REF(C,A36),REF(C,A36),A0*0.37,0-1)COLORLIGREEN;
A37:=INTPART(CURRBARSCOUNT<200 AND IF(A0>0,A0*0.73,0));
STICKLINE(CURRBARSCOUNT<36 AND A37>0,REF(C,A37),REF(C,A37),A0*0.27,0-1)COLORLIGREEN;
A38:=INTPART(IF(A0>0,A0*0.83,0));
STICKLINE(CURRBARSCOUNT<36 AND A38>0,REF(C,A38),REF(C,A38),A0*0.17,0-1)COLORLIGREEN;
A39:=INTPART(IF(A0>0,A0*0.93,0));
STICKLINE(CURRBARSCOUNT<36 AND A39>0,REF(C,A39),REF(C,A39),A0*0.07,0-1)COLORLIGREEN;
A1:=INTPART(IF(A0>0,A0*0.1,0));
STICKLINE(A1>0,REF(C,A1),REF(C,A1),A0*0.9,0),COLORWHITE;
DRAWNUMBER(A1>0,REF(C,A1)*1.01,REF(C,A1))COLORYELLOW;
DRAWTEXT(A1>0,REF(C,A1)*1.01,_______90%)COLORWHITE;
A2:=INTPART(IF(A0>0,A0*0.2,0));
STICKLINE(A2>0,REF(C,A2),REF(C,A2),A0*0.8,0);
DRAWNUMBER(A2>0,REF(C,A2)*1.01,REF(C,A2))COLORYELLOW;
DRAWTEXT(A2>0,REF(C,A2)*1.01,_______80%)COLORWHITE;
A3:=INTPART(IF(A0>0,A0*0.3,0));
STICKLINE(A3>0,REF(C,A3),REF(C,A3),A0*0.7,0);
DRAWNUMBER(A3>0,REF(C,A3)*1.01,REF(C,A3))COLORYELLOW;
DRAWTEXT(A3>0,REF(C,A3)*1.01,_______70%)COLORWHITE;
A4:=INTPART(IF(A0>0,A0*0.4,0));
STICKLINE(A4>0,REF(C,A4),REF(C,A4),A0*0.6,0);
A5:=INTPART(IF(A0>0,A0*0.5,0));
STICKLINE(A5>0,REF(C,A5),REF(C,A5),A0*0.5,0);
A6:=INTPART(IF(A0>0,A0*0.6,0));
STICKLINE(A6>0,REF(C,A6),REF(C,A6),A0*0.4,0);
A7:=INTPART(IF(A0>0,A0*0.7,0));
STICKLINE(A7>0,REF(C,A7),REF(C,A7),A0*0.3,0);
A8:=INTPART(IF(A0>0,A0*0.8,0));
STICKLINE(A8>0,REF(C,A8),REF(C,A8),A0*0.2,0);
A9:=INTPART(IF(A0>0,A0*0.9,0));
STICKLINE(A9>0,REF(C,A9),REF(C,A9),A0*0.1,0);
DRAWKLINE(H,O,L,C);

分享: