「通达信」红绿接力主图指标公式

N:=30;M:=3;
GJ:=(C H L O)/4;阻:=L (GJ-L) (C-L);支:=L (C-GJ);
压力:REF(阻 , 1),NODRAW,COLOR00FF00;
支撑:REF(支 , 1),NODRAW,COLORYELLOW;
stICKLINE(ISLASTBAR,压力,压力,30,1),LINethICK2,COLOR00FF00;
STICKLINE(ISLASTBAR,支撑,支撑,30,1),LINETHICK2,COLORYELLOW;
{www.gainiangu.com 概念股网_通达信股票指标公式}
下档线:=(((CLOSE LLV(LOW,13)) / (HHV(high,13) LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);KKK:=SMA(RRRSV,3,1);ddd:=((3 * RRRSV) (2 * KKK));
JJ12:=(((CLOSE LLV(LOW,55)) / (HHV(HIGH,55) LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);K24:=SMA(RSV24,3,1);D24:=((3 * RSV24) (2 * K24));
顶部:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
决策:IF(ISLASTBAR,顶部,DRAWNULL),COLORMAGENTA;
STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORMAGENTA;
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:IF(ISLASTBAR,底部,DRAWNULL),COLORRED,LINETHICK2;
STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORRED;
aaa:=(3*C H L O)/6;
VAR1:=(8*AAA 7*REF(AAA,1) 6*REF(AAA,2) 5*REF(AAA,3) 4*REF(AAA,4) 3*REF(AAA,5) 2*REF(AAA,6) REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5) HHV(VAR1,10) HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5) LLV(VAR1,10) LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5) HHV(VAR2,10) HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5) LLV(VAR3,10) LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;
多空线:(MA(CLOSE,3) MA(CLOSE,6) MA(CLOSE,12) MA(CLOSE,24))/4,COLORYELLOW,CIRCLEDOT;
短线:VAR1,COLORMAGENTA,LINETHICK2;
中线:VAR6,COLORCYAN,LINETHICK2;
长线:ema(((SLOPE(CLOSE,21) * 20) CLOSE),42),LINETHICK2,NODRAW,COLORGREEN;
风险参数:MA((MA(C,13)-MA(C,55))/MA(C,13)*100,1),NODRAW,COLORFFFF00;
下行:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN,LINETHICK2;
{持股持币彩色K线}
EMA2:=EMA(CLOSE,2);
BbuY:=CROSS(EMA2,长线);
SEL:=CROSS(长线,EMA2);
STICKLINE((EMA2 >= 长线),LOW,HIGH,0.4,0),COLOR0000FF;
STICKLINE((EMA2 >= 长线),CLOSE,OPEN,3,1),COLOR000077;
STICKLINE((EMA2 >= 长线),CLOSE,OPEN,2.6,1),COLOR000099;
STICKLINE((EMA2 >= 长线),CLOSE,OPEN,2,1),COLOR0000BB;
STICKLINE((EMA2 >= 长线),CLOSE,OPEN,1.3,1),COLOR0000DD;
STICKLINE((EMA2 >= 长线),CLOSE,OPEN,0.4,1),COLOR0000FF;
STICKLINE((EMA2 < 长线),LOW,HIGH,0.4,0),COLORFFFF00;
STICKLINE((EMA2 < 长线),CLOSE,OPEN,3,1),COLOR777700;
STICKLINE((EMA2 < 长线),CLOSE,OPEN,2.6,1),COLOR999900;
STICKLINE((EMA2 < 长线),CLOSE,OPEN,2,1),COLORBBBB00;
STICKLINE((EMA2 < 长线),CLOSE,OPEN,1.3,1),COLORDDDD00;
STICKLINE((EMA2 < 长线),CLOSE,OPEN,0.4,1),COLORFFFF00;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,5,0),COLOR0055FF;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,4.2,0),COLOR0077FF;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,3,0),COLOR0099FF;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,2.2,0),COLOR00BBFF;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,1.5,0),COLOR00DDFF;
STICKLINE((CROSS(EMA2,长线) OR CROSS(长线,EMA2)),OPEN,CLOSE,0.4,0),COLOR00FFFF;

分享: