「通达信」牛魔王主图指标公式

YM:ema(SLOPE((CLOSE high LOW)/3,24)*20 (CLOSE HIGH LOW)/3,48),COLORRED,LINethICK1;
IF(EMA((CLOSE HIGH LOW)/3,3)>=YM,YM,DRAWNULL),DOTLINE,COLORRED;
IF(EMA((CLOSE HIGH LOW)/3,3)<=YM,YM,DRAWNULL),DOTLINE,COLORGREEN;
STICKLINE(EMA((CLOSE HIGH LOW)/3,3)>=YM,LOW,HIGH,0,0),COLORRED;
STICKLINE(EMA((CLOSE HIGH LOW)/3,3)>=YM,CLOSE,OPEN,3,1),COLORRED;
stICKLINE(EMA((CLOSE HIGH LOW)/3,3)<=YM,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(EMA((CLOSE HIGH LOW)/3,3)<=YM,CLOSE,OPEN,3,1),COLORGREEN;
买入力度:=LARGEINTRDVOL*100/VOL;
卖出力度:=LARGEOUTTRDVOL*100/VOL;
买卖力度:=买入力度/卖出力度;
macd价格1:=EMA(CLOSE,3) EMA(CLOSE,9);
dea1021:=EMA((EMA(MACD价格1,102) EMA(MACD价格1,204)),9);
DEA511:=EMA((EMA(MACD价格1,51) EMA(MACD价格1,102)),9);
DEA36361:=EMA((EMA(MACD价格1,36) EMA(MACD价格1,72)),9);
DEA24241:=EMA((EMA(MACD价格1,24) EMA(MACD价格1,48)),9);
DEA18181:=EMA((EMA(MACD价格1,18) EMA(MACD价格1,36)),9);
DEA661:=EMA((EMA(MACD价格1,6) EMA(MACD价格1,12)),9);
DEA331:=EMA((EMA(MACD价格1,3) EMA(MACD价格1,9)),9);
DEA12121:=EMA((EMA(MACD价格1,12) EMA(MACD价格1,24)),9);
MACD24241:=2*((EMA(MACD价格1,24) EMA(MACD价格1,48))-DEA24241);
HH1:=(20*H 19*REF(H,1) 18*REF(H,2) 17*REF(H,3) 16*REF(H,4) 15*REF(H,5) 14*REF(H,6)
13*REF(H,7) 12*REF(H,8) 11*REF(H,9) 10*REF(H,10) 9*REF(H,11) 8*REF(H,12)
7*REF(H,13) 6*REF(H,14) 5*REF(H,15) 4*REF(H,16) 3*REF(H,17) 2*REF(H,18)
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL1:=(20*L 19*REF(L,1) 18*REF(L,2) 17*REF(L,3) 16*REF(L,4) 15*REF(L,5) 14*REF(L,6)
13*REF(L,7) 12*REF(L,8) 11*REF(L,9) 10*REF(L,10) 9*REF(L,11) 8*REF(L,12)
7*REF(L,13) 6*REF(L,14) 5*REF(L,15) 4*REF(L,16) 3*REF(L,17) 2*REF(L,18)
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H1:=EMA(HH1,90),COLORRED,LINETHICK1;
D90L1:=EMA(LL1,90),COLORRED,LINETHICK1;
D901:=(D90H1 D90L1)/2;
Y1M:=EMA(SLOPE((CLOSE HIGH LOW)/3,24)*20 (CLOSE HIGH LOW)/3,48);
cci151:=((HIGH LOW CLOSE)/3-MA((HIGH LOW CLOSE)/3,15))/(0.015*AVEDEV((HIGH LOW CLOSE)/3,15));
CCI101:=((HIGH LOW CLOSE)/3-MA((HIGH LOW CLOSE)/3,10))/(0.015*AVEDEV((HIGH LOW CLOSE)/3,10));
CCI51:=((HIGH LOW CLOSE)/3-MA((HIGH LOW CLOSE)/3,5))/(0.015*AVEDEV((HIGH LOW CLOSE)/3,5));
CCI31:=((HIGH LOW CLOSE)/3-MA((HIGH LOW CLOSE)/3,3))/(0.015*AVEDEV((HIGH LOW CLOSE)/3,3));
CCI买点定位1:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI151,1)>0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位2:=CROSS(CCI31,0) AND CCI51>REF(CCI51,1) AND REF(CCI51,1)<-100 AND REF(CCI151,1)>0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位3:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI101,1)>0 AND REF(CCI101,1)>REF(CCI151,1);
CCI买点定位:=CCI买点定位1=1 OR CCI买点定位2=1 OR CCI买点定位3=1;
金牛1:=CCI买点定位=1 AND DEA12121>DEA18181 AND DEA18181>DEA24241 AND DEA24241>DEA36361 AND DEA36361>DEA511 AND DEA511>=DEA1021 AND DEA18181>REF(DEA18181,1) AND DEA24241>REF(DEA24241,1) AND DEA36361>REF(DEA36361,1) AND DEA511>REF(DEA511,1) AND DEA1021>REF(DEA1021,1) AND DEA36361>0 AND DEA331>0;
金牛2:=CCI买点定位=1 AND DEA12121>DEA18181 AND DEA18181>DEA24241 AND DEA24241>DEA36361 AND DEA18181>DEA1021 AND DEA18181>REF(DEA18181,1) AND DEA24241>REF(DEA24241,1) AND DEA36361>REF(DEA36361,1) AND DEA511>REF(DEA511,1) AND DEA1021>REF(DEA1021,1) AND DEA18181>0 AND DEA331>0;
金牛:=金牛1=1 OR 金牛2=1;
VOL比:=VOL/REF(VOL,1);
高度:=(D90H1-D90L1)*2 D90H1;
PBX11:=(EXPMA((CLOSE HIGH LOW)/3,4) EMA((CLOSE HIGH LOW)/3,4*2) EMA((CLOSE HIGH LOW)/3,4*4))/3;
PBX22:=(EXPMA((CLOSE HIGH LOW)/3,5) EMA((CLOSE HIGH LOW)/3,5*2) EMA((CLOSE HIGH LOW)/3,5*4))/3;
PBXHH:=(EXPMA(H,2) EMA(H,2*2) EMA(H,2*4))/3,COLORGREEN,LINETHICK1;
PBXLL:=(EXPMA(L,2) EMA(L,2*2) EMA(L,2*4))/3,COLORRED,LINETHICK1;
牛魔王:=(CLOSE HIGH LOW)/3>Y1M AND 金牛=1 AND PBX11>PBX22 AND 买卖力度>1 AND C<高度;
STICKLINE(牛魔王=1,LOW,HIGH,0,0),COLORYELLOW;
STICKLINE(牛魔王=1,CLOSE,OPEN,4,0),COLORYELLOW;
DRAWicoN(牛魔王=1,L,5);
YM高:=EMA(SLOPE(H,24)*20 H,48),COLORGREEN,DOTLINE;
YM低:=EMA(SLOPE(L,24)*20 L,48),COLORGREEN,DOTLINE;
止损:=(HIGH LOW)/2-(YM高-YM低)*1.5;
STICKLINE(牛魔王=1,止损,止损,100,0),LINETHICK1,COLORWHITE;
DRAWTEXT(牛魔王=1,止损*0.98,↖【止损】),COLORWHITE;

分享: