「大智慧」趋势成本指标公式

admin炒股技巧2019-12-09 22:43:5924

input:y(2011,1991,2099),m(6,1,12),d(30,1,31),y1(2011,1992,2099),m1(9,1,12),d1(31,1,31),y2(2011,1992,2099),m2(9,1,12),d2(31,1,31);
{成交额}
成交额:AMOUNT/10000000,COLORb400ff;
STICKLINE(成交额,成交额,0,6,0),COLORGRAY;
mm:=(y-1900)*10000 m*100 d;{最早日期}
mb:=(y1-1900)*10000 m1*100 d1;{中间日期}
mn:=(y2-1900)*10000 m2*100 d2;{最晚日期}
zz:=LAST(DATE>mm) 1;{DATE-1900年以来年月日}
zb:=LAST(DATE>mb) 1;{中间}
zc:=LAST(DATE>mn) 1;
VERTLINE(zz=2,1),COLORgreen;{绘起点垂直线}
VERTLINE(zb=2,1),COLORffffff;{绘中间垂直线}
VERTLINE(zc=2,1),COLORFFFF00;{绘终点垂直线}
个股季:=ref(sum(AMOUNT,zz-zb)/sum(VOL*100,zz-zb),zb);
个股今:=ref(sum(AMOUNT,zb-zc)/sum(VOL*100,zb-zc),zc);
指数季:=ref(ma(c,zz-zb),zb);
指数今:=ref(ma(c,zb-zc),zc);
if zb>1 then begin 季区间成本:if(CATEGORY=1,个股季,指数季),COLORFFFFFF,LINETHICK0;end;{季区间成本}
if zc>1 then begin 今区间成本:if(CATEGORY=1,个股今,指数今),COLORFFFFFF,LINETHICK0;end;{今区间成本}
季区间换手:=ref(SUM(VOL,zz-zb)/CAPITAL*100,zb);
今区间换手:=ref(SUM(VOL,zb-zc)/CAPITAL*100,zc);
if zb>1 then begin 季区间换手%:if(CATEGORY=1,季区间换手,指数季),COLORFFFF00,LINETHICK0;end;{季区间换手}
if zc>1 then begin 今区间换手%:if(CATEGORY=1,今区间换手,指数今),COLORFFFF00,LINETHICK0;end;{今区间换手}
DRAWTEXT(zz=2,(LLVALL(HIGH) HHVALL(HIGH))/2,起点),LINETHICK3,ALIGN1,COLORgreen;
DRAWTEXT(zb=2,(LLVALL(HIGH) HHVALL(HIGH))/2,中点),LINETHICK3,ALIGN1,COLORffffff;
DRAWTEXT(zc=2,(LLVALL(HIGH) HHVALL(HIGH))/2,终点),LINETHICK3,ALIGN1,COLORFFFF00;
drawtextABS(700,10,●季区间成本 NUMTOSTRN(季区间成本,2) 元),colorffFFff;
drawtextABS(960,10,●今区间成本 NUMTOSTRN(今区间成本,2) 元),colorffFFff;
drawtextABS(700,25,●季区间换手 NUMTOSTRN(季区间换手%,1) %),colorffFF00;
drawtextABS(960,25,●今区间换手 NUMTOSTRN(今区间换手%,1) %),colorffFF00;
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
A:SMA(VAR1,7,1),LINETHICK1,COLOR00FFFF;
VAR2:=SMA(A,5,1);
B:IF(CROSS(A,VAR2) AND CROSS(MA(C,5),MA(C,13) AND A>50) ,VAR2*2,VAR2),COLORYELLOW;
PARTLINE(B,B>REF(B,1),RGB(255,0,0),BDRAWTEXT(CROSS(B,A) ,B,止赢!!),color0000ff;
DRAWTEXT(CROSS(A,B) ,A,买),color00ffff;
出局:ref(A,BARSLAST(cross(ref(A,3),A)) 1),POINTDOT,colorD3A9FF,LINETHICK2;
{引用}
增仓大股东:=笑看庄舞.增仓大股东数#day;
减仓大股东:=笑看庄舞.减仓大股东数#day;
新进大股东:=笑看庄舞.新进大股东数#day;
未变大股东:=笑看庄舞.未变大股东数#day;
DRAWTEXTabs(700,45,●年报增仓大股东: NUMTOSTRN(增仓大股东,0) ★ 减仓大股东: NUMTOSTRN(减仓大股东,0) ◆ 新进大股东: NUMTOSTRN(新进大股东,0) ★ 未变大股东: NUMTOSTRN(未变大股东,0)),color00ffff;
{www.gainiangu.com 概念股网_大智慧股票指标公式}
DRAWTEXTABS(150,20,●二季前10流占 NUMTOSTRN(PFFINON(4252,2011,0630),2) %),COLOR00FFFF;
DRAWTEXTABS(450,20,●三季前10流占 NUMTOSTRN(PFFINON(4252,2011,0930),2) %),COLOR00FF00;
DRAWTEXTABS(700,60,●年报前10流占 NUMTOSTRN(PFFINON(4252,2011,1231),2) %),COLOR0098FF;
二季合计持股:=PFFINON(4251,2011,0630)/10000;
三季合计持股:=PFFINON(4251,2011,0930)/10000;
年报合计持股:=PFFINON(4251,2011,1231)/10000;
三季前十增减%:=(三季合计持股-二季合计持股)/二季合计持股*100;
DRAWTEXTABS(450,45,★三季前十流通股东合计持股变化率: NUMTOSTRN(三季前十增减%,2) %),ColorffffFF;
年报前十增减%:=(年报合计持股-三季合计持股)/三季合计持股*100;
DRAWTEXTABS(700,80,★年报前十流通股东合计持股变化率: NUMTOSTRN(年报前十增减%,2) %),ColorffffFF;

分享: