「通达信」龙族主图指标公式

飞:EMA(CLOSE,6);
州:EMA(CLOSE,12),POINTDOT;
龙:MA(CLOSE,33),,COLORFF00FF,LINETHICK3;
龙族: IF(龙<=REF(龙,1),龙,DRAWNULL),COLOR00FFFF,LINETHICK3;
飞A:=XMA(XMA(XMA(EMA(CLOSE,1),2),2),2);
DRAWTEXT(CROSS(飞A,REF(飞A,1)),L,买),COLORFF00FF;
DRAWTEXT(CROSS(REF(飞A,1),飞A),H,卖),COLOR00FF00;
阻力1:REFDATE(REF(HHV(H,33),1),DATE),COLORGRAY;


底:REFDATE(REF(LLV(L,22),1),DATE),COLORGRAY;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.91,1,0,HYBLOCK),COLORYELLOW;
{逐笔大单DDE}
大单动向:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),NODRAW;{逐笔买入大单成交-逐笔卖出大单成交)*10000/流通股本(股}
A01:=MIN(O,C);
B01:=ABS(O-C);
STICKLINE(大单动向>0,A01,A01 B01/3.

2,0),COLOR0000AA;
STICKLINE(大单动向<0,A01 B01,A01 B01/1.8,2.2,0),COLOR00AA00;
{资金}
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.


TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B) (大B),NODRAW;
大宗出:=(超S) (大S),NODRAW;
非大宗进:=(中B) (小B),NODRAW;
非大宗出:=(中S) (小S),NODRAW;
主力净流入:=(超B 大B)-(超S 大S),COLORRED,NODRAW;
散户净流入:=(中B 小B)-(中S 小S),COLORRED,NODRAW;
净流入:=(超B 大B 中B 小B)-(超S 大S 中S 小S),COLORRED,NODRAW;


大单流入限制:=IF((超B 大B 超S 大S)=0,0,大单流入);
大单流出比:=(超S 大S)/(超B 大B 超S 大S)*100,NODRAW;
大单流出限制:=IF((超B 大B 超S 大S)=0,0,大单流出比);
总流入比:=(超B 大B 中B 小B)/(超B 大B 中B 小B 超S 大S 中S 小S)*100,NODRAW;
总流出比:=(超S 大S 中S 小S)/(超B 大B 中B 小B 超S 大S 中S 小S)*100,NODRAW;
成交总量:=(超B 大B 中B 小B 超S 大S 中S 小S),NODRAW;
机构参与度:=(超B 超S 大B 大S)/成交总量*100,COLORYELLOW,NODRAW;


大单强度限制:=IF(大单强度=0,-100,大单强度);
大单强度比:=IF(大单强度>=0,(大单强度限制 100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;
超单强度:=(超B-超S)/(超B 超S)*100,COLORYELLOW,NODRAW;
超单强度限制:=IF(超单强度=0,-100,超单强度);
超单强度比:=IF(超单强度>0,(超单强度限制 100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;


DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(25,150,250),RGB(250,125,0)));
DRAWRECTREL(102,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,132,950,IF(CONST(非大宗进>0),RGB(250,125,0),RGB(25,150,250)));
DRAWRECTREL(134,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,164,950,IF(CONST(非大宗出>0),RGB(25,150,250),RGB(250,125,0)));


DRAWTEXT_FIX(1,0.00,0.95,0,STRCAT(STRCAT(主力 ,CON2STR(主力净流入,0)),万)),COLORMAGENTA;
DRAWTEXT_FIX(1,0.10,0.95,0,STRCAT(STRCAT(散户 ,CON2STR(散户净流入,0)),万)),COLORCYAN;
DRAWTEXT_FIX(1,0.20,0.95,0,STRCAT(STRCAT(净流入 ,CON2STR(净流入,0)),万)),COLORYELLOW;
主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;


主卖:=主卖A*100/(主买A 主卖A),NODRAW,COLORGREEN;
大单买比:=LARGEINTRDVOL*100/(LARGEINTRDVOL LARGEOUTTRDVOL);
大单卖比:=LARGEOUTTRDVOL*100/(LARGEINTRDVOL LARGEOUTTRDVOL);
主力净买量:=(LARGEINTRDVOL-LARGEOUTTRDVOL),COLORYELLOW,NODRAW;
主动买卖差:=(ACTINVOL-ACTOUTVOL),COLORMAGENTA,NODRAW;
主力资金差:=((L2_AMO(0,0) L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1)))/10000,COLORCYAN,NODRAW;


主力卖力度:=LARGEOUTTRDVOL*100/VOL;
主买力度比:=主力买力度/(主力买力度 主力卖力度)*100,NODRAW;
主卖力度比:=主力卖力度/(主力买力度 主力卖力度)*100,NODRAW;
力度比限制:=IF((LARGEINTRDVOL LARGEOUTTRDVOL)=0,0,大单买比);
JGV:=(L2_VOL(0,0) L2_VOL(0,1))*VOL/100000000,COLORRED;
DHV:=(L2_VOL(1,0) L2_VOL(1,1))*VOL/100000000,COLORFF00FF;


SHV:=(L2_VOL(3,0) L2_VOL(3,1))*VOL/100000000,COLORFFFFFF;
NOTEXT大量动向:=MA((JGV DHV),5),COLORYELLOW;
超级大量:=JGV,COLOR0000FF,NODRAW;
机构大量:=DHV,COLORMAGENTA,NODRAW;
大量博弈:=(JGV DHV),COLORYELLOW,NODRAW;
小量博弈:=(ZHV SHV),COLORWHITE,NODRAW;
大量资金比:=大量博弈/(ABS(JGV) ABS(DHV) ABS(ZHV) ABS(SHV))*100,COLORYELLOW,NODRAW;


大量强度比:=IF(大量资金比>0,(大量资金比限制 100)/2,IF(大量资金比<0,100-ABS((大量资金比限制-100)/2),0)),COLORGREEN,NODRAW;
小量资金比:=小量博弈/(ABS(JGV) ABS(DHV) ABS(ZHV) ABS(SHV))*100,COLORYELLOW,NODRAW;
小量强度比:=IF(小量资金比>=0,(小量资金比 100)/2,100-ABS((小量资金比-100)/2)),COLORCYAN,NODRAW;
MVR:=REF(MA(V,5),1);
FVR:=REF(V,1);


量能比:=V/(V PVR)*100/FROMOPEN*240;

分享: