「通达信」高抛低吸操盘主图指标公式

MA5:MA(CLOSE,5),COLORFF00FF,LINethICK2;
ma10:MA(CLOSE,10),COLOR00FFFF,LINETHICK1;
MA30:MA(CLOSE,30),COLORFFFF00,LINETHICK1;
MA60:MA(CLOSE,60);
零轴:=DYNAINFO(3)*1,COLOR0000FF;
stICKLINE(1,90/100 零轴,90/100 零轴,2,0),COLOR00BBBB;
STICKLINE(1,10/100 零轴,10/100 零轴,2,0),COLORBBBBBB;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(high,9)-LLV(LOW,9))*100 50/100;
K:=sma(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
KK:=零轴 K/100;
DDK:=零轴 D/100;
JJ:=零轴 J/100;
EEK:=50/100 零轴;
DRAWBAND(KK,RGB(255,170,0),EEK,RGB(0,80,80));
DRAWBAND(JJ,RGB(200,0,180),KK,RGB(120,120,120));
IF(JJ>=REF(JJ,1),JJ,DRAWNULL),COLOR00FF00;
日K:=KD.K(9,3,3);
日D:=KD.D(9,3,3);
STICKLINE(K>=D AND C>=O,C,O,3,0),COLOR0000FF;
{STICKLINE(K>=D AND C>=O,C,O,3,0),COLOR0000DD;
STICKLINE(K>=D AND C>=O,C,O,3,0),COLORRED;}
STICKLINE(K>=D AND C{STICKLINE(K>=D AND CdddD;
STICKLINE(K>=D AND CSTICKLINE(K=O,C,O,3,1),COLORFF00FF;
STICKLINE(K月K:=KDJ.K#MONTH(9,3,3);
月D:=KDJ.D#MONTH(9,3,3);
周K:=KDJ.K#WEEK(9,3,3);
周D:=KDJ.D#WEEK(9,3,3);
DRAWTEXT_FIX(ISLASTBAR,0.04,0.60,0,KDJ ),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.65,0,月K= ),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.65,0, 月K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.7,0,月D=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.7,0,月D),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.75,0,周K=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.75,0,周K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.8,0,周D=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.8,0,周D),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.85,0,日K=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.85,0,日K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.9,0,日D=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.9,0,日D),COLORFFFFFF;
月DIF:=macd.DIF#MONTH(12,26,9);
dea:=MACD.DEA#MONTH(12,26,9);
周DIF:=MACD.DIF#WEEK(12,26,9);
周DEA:=MACD.DEA#WEEK(12,26,9);
日DIF:=MACD.DIF(12,26,9);
日DEA:=MACD.DEA(12,26,9);
DRAWTEXT_FIX(ISLASTBAR,0.13,0.60,0,MACD ),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.65,0,月DIF= ),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.65,0, 月DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.7,0,月DEA=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.7,0,月DEA),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.75,0,周DIF=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.75,0,周DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.8,0,周DEA=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.8,0,周DEA),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.85,0,日DIF=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.85,0,日DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.9,0,日DEA=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.9,0,日DEA),COLORFFFFFF;
TYP:=(HIGH LOW CLOSE)/3;
日CCI:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
周CCI:=(TYP-MA(TYP,21))/(0.015*AVEDEV(TYP,21));
月CCI:=(TYP-MA(TYP,9))/(0.015*AVEDEV(TYP,9));
DRAWTEXT_FIX(ISLASTBAR,0.235,0.75,0,CCI),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.80,0,月CC=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.80,0,月CCI),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.85,0,周CCI=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.85,0,周CCI),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.90,0,日CCI=),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.90,0,日CCI),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.1,0.03,0,★【彩色K线】★【红色K线-日kdj金叉阳线】【黄色K线-日KDJ金叉阴线
【粉色K线-日KDJ死叉阳线】【青色K线-日KDJ死叉阴线】★),COLORFFFF00;

分享: